Annoying Eclipse message about JavaHL on Ubuntu

Posted June 21st, 2010 in Tehnikalije by Metod

How to get rid of it?

First of, we need to install some libraries:

  1. sudo apt-get install libsvn-java

Once this is done, we need to tell JVM (Java Virtual Machine) to include the path to our new libsvnjavahl-1.so file, when searching for extensions. We can do this in the eclipse configuration file. It is located inside the directory in which you installed Eclipse and is called eclipse.ini.

Find the line -vmargs and after it (in a new line) add this one:

  1. -Djava.library.path=/usr/lib/jni

Restart Eclipse and you’re done.

Tested on Eclipse Galileo (3.5.2) through all latest releases on Ubuntu 10.04 and onward.